Piston rod not latching.

Piston rod not latching.

Postby Kelvin » Mon Jan 16, 2017 1:44 am

Hello, Newbie here.
I decided to re-lube and polish my TX-200 MKIII for the first time yesterday.
Now my piston rod will not latch.

What I did:
I removed and replaced lube, polished spring ends, and trigger.
This rifle had no spacers, just spring,top hat, tube guide and a washer between the tube guide and spring.
The washer had a nick on its edge so I polished that out while polishing the spring ends.
The trigger seems to work fine outside the rifle.

Please help.
Kelvin
 
Posts: 6
Joined: Mon Jan 16, 2017 1:15 am

Re: Piston rod not latching.

Postby Bosun » Mon Jan 16, 2017 11:18 am

Hello Kelvin,

I wish I could help. I had the same problem a couple of years ago, but can't for the life of me remember what I did to fix it. I'll do my best to wring out the grey matter and post if I come up with anything. I know it sounds obvious, but If the trigger is functioning OK, presumably it has to be the piston not travelling far enough.
Air Arms ProSport 0.177 Walnut, MTC Mamba Lite 3-12x44
Air Arms TX200 HC 0.177 Walnut, MTC Mamba Lite 3-12x44
Weihrauch HW75 Pistol
Umarex Colt M1911A1 pellet Pistol
Umarex Beretta 92FS pellet Pistol
Bosun
 
Posts: 95
Joined: Sat Feb 28, 2015 1:06 pm
Location: Essex

Re: Piston rod not latching.

Postby Kelvin » Mon Jan 16, 2017 3:52 pm

Thank you, Bosun.
I might order a tune kit that includes the spring, that should correct my problem.
But, I still want to know what I did wrong.
Kelvin
 
Posts: 6
Joined: Mon Jan 16, 2017 1:15 am

Re: Piston rod not latching.

Postby Kelvin » Tue Jan 17, 2017 4:06 am

I removed the top hat, and it still will not latch.
Kelvin
 
Posts: 6
Joined: Mon Jan 16, 2017 1:15 am

Re: Piston rod not latching.

Postby Bosun » Tue Jan 17, 2017 8:47 am

Good morning Kelvin,

I may be talking a load of eyewash, but I seem to recall that while the trigger appears to work "off-rifle", it needs to be re-set before re-assembly.
Air Arms ProSport 0.177 Walnut, MTC Mamba Lite 3-12x44
Air Arms TX200 HC 0.177 Walnut, MTC Mamba Lite 3-12x44
Weihrauch HW75 Pistol
Umarex Colt M1911A1 pellet Pistol
Umarex Beretta 92FS pellet Pistol
Bosun
 
Posts: 95
Joined: Sat Feb 28, 2015 1:06 pm
Location: Essex

Re: Piston rod not latching.

Postby pelletcaster » Tue Jan 17, 2017 8:48 am

Kelvin wrote:...What I did:
I ... polished ... and trigger...


That sounds like you disassembled and reassembled the trigger.
Check trigger weight (screw) - maybe too light.
Or stage 1 and/or stage 2 scews set not properly.

Did you pull the trigger after installation before trying to cock?
May be it's still set.

If you try to cock outside of stock - how does the spring behave?
Live is a journey - not a destination.
-----------------------------------------
AA TX200 HC / LGU Master / LGV-CU / HW35 / HW50s (1974) / HW50S (2015) / HW90 / DIANA 34 T01
DS MK4iS-S / SPA P-12 / CZ200S-Green
pelletcaster
 
Posts: 53
Joined: Mon Feb 16, 2015 10:07 pm
Location: Austria / Carinthia

Re: Piston rod not latching.

Postby Sake-san » Tue Jan 17, 2017 8:51 am

From what you describe I would look at the following and in this order...
1. Ensure that the trigger adjustments (esp 1st stage and weight) are sufficient for the sears to engage, try increasing the adjustment on both
2. Check that front stock screws are not fouling the cocking arm and preventing sufficient movement, try loosening them off a turn or two
3. Check that the compression tube end cap is not loose/undoing

Good luck
TX200/Gary Cane/Sightron SIII 10-50x60
TX200/Gary Cane/Sightron SIII 10x42
TX200 test / analysis gun
User avatar
Sake-san
 
Posts: 543
Joined: Mon May 18, 2015 7:28 pm
Location: France 24

Re: Piston rod not latching.

Postby Kelvin » Tue Jan 17, 2017 5:36 pm

The rifle will fire now.
I left out the top hat, tightened the retaining screw, jerked on the cocking lever(At the end of the cocking stroke) and used strips cut from a plastic bottle to shim the latch plate.

The rifle was working fine before I started this project.
I still do not know what I did wrong.
Kelvin
 
Posts: 6
Joined: Mon Jan 16, 2017 1:15 am

Re: Piston rod not latching.

Postby Sake-san » Tue Jan 17, 2017 6:50 pm

Did you try the potential remedies suggested by pelletcaster and myself?, I suspect that at best you have masked the real issue...
TX200/Gary Cane/Sightron SIII 10-50x60
TX200/Gary Cane/Sightron SIII 10x42
TX200 test / analysis gun
User avatar
Sake-san
 
Posts: 543
Joined: Mon May 18, 2015 7:28 pm
Location: France 24

Re: Piston rod not latching.

Postby Kelvin » Tue Jan 17, 2017 7:25 pm

I think you are right Sake-san,
The front stock screws are not touching the cocking lever.
I have not tried the trigger adjustments, what is the proper adjustment procedure from scratch?
I can not feel much difference from 1st to 2nd stage on the trigger.


Thank you for the help.
Kelvin
 
Posts: 6
Joined: Mon Jan 16, 2017 1:15 am

Next

Return to Spring guns and tuning

Who is online

Users browsing this forum: No registered users and 3 guests